Back to overview
Resolved
Moving to a new domain
Jul 17, 2026 at 9:00pm UTC
–
Jul 17, 2026 at 9:39pm UTC
Affected services
International Web Technolgies
Resolved
Jul 17, 2026 at 9:39pm UTC
Maintenance ended
Affected services
Updated
Jul 17, 2026 at 9:39pm UTC
Successfully moved the root domain. Some services are still available at the old domain and will move to the new domain soon.
Affected services
Created
Jul 17, 2026 at 9:00pm UTC
We are moving to a new domain. Services may be unavailable temporarily.
Affected services